Sensor serials and sensor ranking

5 years 9 months ago #104 by dhj1965
Hi,

I'm a bit confused :unsure:

I have added two sensors to the OS network on sunday, using the feeder software.

When I look at the "my Sensors" on the OS webpage, they are listed as "-1408237544" and "-1408237543". But when I look at the "10-serial.conf" they are listed as "2886729752" and "2886720753"

The "my Sensors" section is showing "-1408237543"/"2886720753" as the 67th for the total qty of messages for the 13/02. But the sensor ranking is showing "90143" as 67th with a much lower msg quantity.

why do I see different serials for my nodes (negative/postive number) and why is the ranking showing different serials on the ranks listed for my sensors?

Is it a bug ? Or a feature ? Or am I just confused with all that numbers :woohoo: ?

best...
dhj.
The following user(s) said Thank You: schaefer

Please Log in or Create an account to join the conversation.

5 years 9 months ago #106 by schaefer
Hi dhj,

this is a known issue and will be fixed at some point. The reason is that we set the 32-th bit of the serial number (32 bit integer) to 1 if it is a feeder. Our web server interprets the number as a signed 32-bit integer, while the feeder on the device interprets it as a 32 bit unsigned integer. So it's actually the same (binary) number, just two different interpretations.

This will be harmonized soon.

The rankings are indeed a bit mixed up at the moment. We'll fix this as soon as possible :-) Thanks for reporting!

Matthias

Please Log in or Create an account to join the conversation.

5 years 9 months ago #107 by dhj1965
Hi Matthias,

thanks for the explanation.

I thought of an signed/unsigned issue earlier, but I obviously made a big mistake in my calculations which made me think of a bug...

best...
Detlev

Please Log in or Create an account to join the conversation.

5 years 9 months ago #108 by schaefer
The relationship is 2886720753 - 2^32 = 2886720753 - 4294967296 = -1408246543

Please Log in or Create an account to join the conversation.

5 years 9 months ago #109 by dhj1965
thanks :) now I see my mistake, it was a quite stupid one :woohoo:

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum
This website uses cookies to offer you the best experience of our services. By using this website you agree to our privacy policy!