Online in logfiles but offline on the web

3 years 1 month ago #516 by krono
Hi everybody, sorry about my poor english.

I have installed opensky feeder on Rasperry Pi where I have FR24 feeder too. Opensky feeder is connected to dump1090 at port 30002 but no data is receiver by the feeder. I think is the correct port because others applications like VirtualRadar o PlanePlotter connects properly with Beast protocol to this port and all it's ok.

As you can see on log, connection to opensky network is ok and the feeder is online, but my receiver is offline on my receiver profile on opensky web. Maybe because there is no data to send?? There are two warnings that I don't know if they are important. Some private data have been replaced by XXXX.

Jul 28 06:00:54 raspberrypi systemd[1]: Started OpenSky Daemon.
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Initialize STAT
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Initialize POS
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Initialize DEVTYPE
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Initialize NET
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Initialize TB
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Initialize SERIAL
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Initialize BUF
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Initialize RELAY
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Initialize RC
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Initialize FILTER
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Initialize RECV
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Start STAT
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Start POS
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Start DEVTYPE
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Start NET
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Start TB
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Start SERIAL
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Start RELAY
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Start RC
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Start FILTER
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [COMP] Start RECV
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [INPUT] Trying to connect to 'localhost': [::1]:30002
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [WARN] [INPUT] Could not connect: Connection refused (111)
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [INPUT] Trying to connect to 'localhost': [127.0.0.1]:30002
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [INPUT] connected to 'localhost'
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [WARN] [RC] Out of Sync: got 0x40 instead of 0x1a
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [NET] Trying to connect to 'collector.opensky-network.org': [194.209.200.4]:10004
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [NET] connected to 'collector.opensky-network.org'
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [LOGIN] Sending Device ID 5, Version 2.1.7
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [LOGIN] Sending Serial Number -140823XXXX
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [GPS] Sending position +XX.XXXX<C2><B0>, -X.XXXX<C2><B0>, +590.00m
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [LOGIN] Sending Username 'krono'
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [TB] Setting sync filter: 0
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [INFO] [TB] Setting ext squitter only filter: 0

Thank you!!!!

Please Log in or Create an account to join the conversation.

3 years 1 month ago #517 by engel
Hi krono,

this line is a bit strange:
Jul 28 06:00:54 raspberrypi openskyd-dump1090[1489]: [WARN] [RC] Out of Sync: got 0x40 instead of 0x1a

It seems like there is no beast protocol on port 30002, maybe you should try port 30005.

Regards

Please Log in or Create an account to join the conversation.

3 years 1 month ago #518 by krono
Hi engel,

Than you but I tried and this is the result:

Jul 31 17:25:19 raspberrypi openskyd-dump1090[29166]: [INFO] [INPUT] Trying to connect to 'localhost': [127.0.0.1]:30005
Jul 31 17:25:19 raspberrypi openskyd-dump1090[29166]: [WARN] [INPUT] Could not connect: Connection refused (111)
Jul 31 17:25:19 raspberrypi openskyd-dump1090[29166]: [INFO] [INPUT] Trying to connect to 'localhost': [::1]:30005
Jul 31 17:25:19 raspberrypi openskyd-dump1090[29166]: [WARN] [INPUT] Could not connect: Connection refused (111)

Others ports different from 30002 gives same results.

Please Log in or Create an account to join the conversation.

3 years 1 month ago #519 by engel
Ok, change it to 30002 again (sorry, I missed you wrote that other feeders work on that port).
Then wait for ~10 minutes, the feeder writes some statistics into the log. Maybe I can see something from there.

Regards,
Markus

Please Log in or Create an account to join the conversation.

3 years 1 month ago #520 by engel
Hi again,
I just discovered that your dump1090 is sending the AVR raw format, e.g. "@016CE3671C745DFFE7AB7BFCAB;".
This is NOT the binary beast protocol, which the feeder expects.
You are either using an incompatible dump1090 branch or you have not enabled the beast binary protocol (I think it's the "--net-beast" option).

Regards,
Markus

Please Log in or Create an account to join the conversation.

3 years 1 month ago #521 by krono
Hi,

That is the key, engel, thank you very much. I discovered that fr24feed starts dump1090-mutability with options that make Beast protocol port is not open.

I dont know how to change that, so I have connected another SDR device and I have started other instance of dump1090-mutability that open port 30005 for Beast protocol, and my flights are now arriving to opensky-network page.

Thank you very much!!

Regards,
Krono.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum
This website uses cookies to offer you the best experience of our services. By using this website you agree to our privacy policy!